/system/device-mode/update container=yes
/container config
set registry-url=https://registry-1.docker.io
/interface bridge
add name=Docker
/ip address
add address=10.0.0.1/24 interface=Docker
/ip firewall nat
add chain=srcnat src-address=10.0.0.0/24 action=masquerade
/interface veth
add address=10.0.0.12/24 gateway=10.0.0.1 name=veth-pihole
/interface bridge port
add bridge=Docker interface=veth-pihole
/container envs
add key=TZ name=pihole_envs value=Asia/Bangkok
add key=WEBPASSWORD name=pihole_envs value=mypassword
add key=DNSMASQ_USER name=pihole_envs value=root
/container mounts
add dst=/etc/pihole name=pihole-etc src=/pihole/etc-pihole
add dst=/etc/dnsmasq.d name=pihole-dnsmasq src=/pihole/etc-dnsmasq.d
/container
add interface=veth-pihole remote-image=pihole/pihole:latest envlist=pihole_envs mounts=pihole-etc,pihole-dnsmasq start-on-boot=yes logging=yes
/container config
set registry-url=https://registry-1.docker.io
/interface bridge
add name=Docker
/ip address
add address=10.0.0.1/24 interface=Docker
/ip firewall nat
add chain=srcnat src-address=10.0.0.0/24 action=masquerade
/interface veth
add address=10.0.0.12/24 gateway=10.0.0.1 name=veth-pihole
/interface bridge port
add bridge=Docker interface=veth-pihole
/container envs
add key=TZ name=pihole_envs value=Asia/Bangkok
add key=WEBPASSWORD name=pihole_envs value=mypassword
add key=DNSMASQ_USER name=pihole_envs value=root
/container mounts
add dst=/etc/pihole name=pihole-etc src=/pihole/etc-pihole
add dst=/etc/dnsmasq.d name=pihole-dnsmasq src=/pihole/etc-dnsmasq.d
/container
add interface=veth-pihole remote-image=pihole/pihole:latest envlist=pihole_envs mounts=pihole-etc,pihole-dnsmasq start-on-boot=yes logging=yes